Thursday, 29 April 2010

Ubuntu 10 Lucid is here

Ubuntu's long awaited new distribution has been released. A lot of new features and updates and the all new colors from Ubuntu is top of the log.

Grab it now, or wait for your local mirror.

Hit www.ubuntu.com for details.

Tuesday, 20 April 2010

Google Chrome Pins


Was looking for ways to use less desktop on my netbook, and found this very nice tip.

Pin the tabs in Google Chrome, and then add make them start like that every time by adding:

--pinned-tab-count=x

to the shortcut for Chrome. Change the X to the amount of tabs you have when starting Chrome.

Full story over at HowToGeek.com under http://www.howtogeek.com/howto/7264/make-google-chrome-open-with-pinned-tabs/

RadarVirtuel.com

So everybody is Tweeting and Blogging this site (http://www.radarvirtuel.com/) about aircraft over UK and the Volcano cloud, but what I found funny is the notice on the site when using IE:

"We strongly advice all Internet Explorer users to switch to another browser, like Firefox, Chrome, Opera or Safari. Internet Explorer is not powerful enough to run this website."

Zoom out as well, 2 birds in the air over Durban.

Now that is funny!

Friday, 16 April 2010

Nokia Light Saber

Last night after a heavy routing training session for the PTA WUG admins, Blaze and BazzDaddy where comparing notes between Iphone and Nexus One.

Or rather what can yours do that mine cannot do!

Look, most of the stuff are gimmicks, but the one that was really cool was the Light Saber app. Or should I rather say BazzDaddy's impression of Luke Skywalker slicing Blaze up with his lightsaber.

So I had a look around and found the Nokia Symbian version of the same app, for free.

Head on over to http://graho.wordpress.com/ and download the free little app and loose a couple of hours in the office, slicing some colleagues in half!

Still, looking for that one amazing thing any other phone can do, that my N97 cannot do.....

Tuesday, 13 April 2010

Welcome back

Strange how technology and fashion are making 360 circles.

Who remembers the old Commodore VIC20? I still have mine, on display in my study. I do not have the PSU or tape drive anymore, but still have the machine.

Now you can get a modern Intel processor machine, all in a keyboard! Just like the old days!

Cybernet (http://www.cybernet.com.tw) has build this little machine to be a Zero-Footprint-PC. With up to Intel Core 2 Quad CPU, 4Gb RAM, 500Gb SATA Hdd and Intel 3100 GPU, this little machine should run Windows 7 no problem.

What next, return of Burning Rubber?

Tuesday, 6 April 2010

ISADSL and MiktoTIK Router

So we have an ISADSL Business Uncapped Shaped service from IS. I've been shouting at them for weeks now, because I just do not get anything out of this service. They looked at it, Telkom looked at it and still nothing.

Now, I did ask them if I could use my own modem, but no, I have to use the modem from them.

So today, I loose my diginet line and have to push the whole company onto my IS ADSL service.

Having users shouting at me, I decided to really look at this problem and after many hours I found that for some reason the router from IS has issues with mishapped MSS and MTU's on the Ethernet. Now this is something I assumed any good router would resolve, but not the one from IS.

So I added "change MSS" mangle rules to the Ethernet on the Mikrotik connected to this router:
/ip firewall mangle
add action=change-mss chain=forward comment="" disabled=no in-interface=ether2 new-mss=clamp-to-pmtu protocol=tcp tcp-flags=syn tcp-mss=1441-65535
add action=change-mss chain=forward comment="" disabled=no new-mss=clamp-to-pmtu out-interface=ether2 protocol=tcp tcp-flags=syn tcp-mss=1441-65535

Now it is strange how well this service performace!

Add some simple Queues:

/queue type add kind=pcq name=PCQ-ISADSL pcq-classifier=src-address,dst-address,src-port,dst-port pcq-limit=50 pcq-rate=0 pcq-total-limit=2000

/queue simple add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=ether2 limit-at=4M/512k max-limit=4M/512k name=ISADSL parent=none priority=1 queue=PCQ-ISADSL/PCQ-ISADSL total-queue=PCQ-ISADSL

/queue interface set ether2 queue=PCQ-ISADSL

And watch this service fly!!!!

Hope this helps somebody.

Windows 11, but for Web

This guy has created Windows 11 on the web. Have a look at https://dev.to/piyush/windows-11-but-for-web-22h1 Source is over at  https://gith...