Skip to main content

ISADSL and MiktoTIK Router

So we have an ISADSL Business Uncapped Shaped service from IS. I've been shouting at them for weeks now, because I just do not get anything out of this service. They looked at it, Telkom looked at it and still nothing.

Now, I did ask them if I could use my own modem, but no, I have to use the modem from them.

So today, I loose my diginet line and have to push the whole company onto my IS ADSL service.

Having users shouting at me, I decided to really look at this problem and after many hours I found that for some reason the router from IS has issues with mishapped MSS and MTU's on the Ethernet. Now this is something I assumed any good router would resolve, but not the one from IS.

So I added "change MSS" mangle rules to the Ethernet on the Mikrotik connected to this router:
/ip firewall mangle
add action=change-mss chain=forward comment="" disabled=no in-interface=ether2 new-mss=clamp-to-pmtu protocol=tcp tcp-flags=syn tcp-mss=1441-65535
add action=change-mss chain=forward comment="" disabled=no new-mss=clamp-to-pmtu out-interface=ether2 protocol=tcp tcp-flags=syn tcp-mss=1441-65535

Now it is strange how well this service performace!

Add some simple Queues:

/queue type add kind=pcq name=PCQ-ISADSL pcq-classifier=src-address,dst-address,src-port,dst-port pcq-limit=50 pcq-rate=0 pcq-total-limit=2000

/queue simple add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=ether2 limit-at=4M/512k max-limit=4M/512k name=ISADSL parent=none priority=1 queue=PCQ-ISADSL/PCQ-ISADSL total-queue=PCQ-ISADSL

/queue interface set ether2 queue=PCQ-ISADSL

And watch this service fly!!!!

Hope this helps somebody.

Comments

  1. Was this a billion router ? I had the same problem with a billion router and once they changed the router to a cisco the problem was resolved.

    Regards
    Galfred

    ReplyDelete

Post a comment

Popular posts from this blog

Double Bunk in Caravan

With our family expanding, we faced a challenge of adding another berth in our caravan, but I did not want to make it permanent.
A couple of options are available, of which one is simply to add a bunk to the single berth. We however did not want to cause any permanent markings on the interior of the caravan .

Netdata + SNMP + Mikrotik

Always wanted to see my Internet line usage as a gauge without having to log into the router.
So today I configured SNMP in Netdata to collect from my Mikrotik router.
/etc/netdata/node.d/snmp.conf:
{
"enable_autodetect": false,
"update_every": 5,
"max_request_size": 100,
"servers": [
{
"hostname": "10.1.1.1",
"community": "public",
"update_every": 5,
"max_request_size": 50,
"options": { "timeout": 20 },
"charts": {
"mikrotik1.cpu": {
"title": "CPU ",
"units": "percentage",
"type": "line",
"family": "cpu",
"dimensions": {
"used": {
&qu…

CasparCG Simple Playlist

It is possible to build a simple playlist as a rundown in the CasparCG client. It will very simply play each item after each other that are on the same layer. In this very simple post I show how to build such a playlist including the very important step of activating the OSC.

The Open Sound Control (OSC) implementation is how the client knows what the server is doing and then being able to send new command back to the server when a piece of media has ended to trigger playback of the next piece. For more details on the OCS, please see http://casparcg.com/wiki/CasparCG_OSC_Protocol